Profile Picture

IMAP service constant shutdown

Posted By BOUTYM Last Year
You don't have permission to rate!
Author
Message
BOUTYM
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 135, Visits: 208
For some reason our IMAP service keeps shutting down.  Only indication other than the stopped service is the Windows application log

Log Name:      Application
Source:        Application Error
Date:          3/2/2017 4:36:08 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      comsrv.growth.local
Description:
Faulting application name: IMAP4d32.exe, version: 2014.5.9.1517, time stamp: 0x536d2bb4
Faulting module name: IMAP4d32.exe, version: 2014.5.9.1517, time stamp: 0x536d2bb4
Exception code: 0xc0000005
Fault offset: 0x000226d0
Faulting process id: 0xd44
Faulting application start time: 0x01d29399d8c57ca8
Faulting application path: C:\Ipswitch\IMail\IMAP4d32.exe
Faulting module path: C:\Ipswitch\IMail\IMAP4d32.exe
Report Id: 3e947c6e-ff90-11e6-ae80-000c29a11e28
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-03-02T21:36:08.000000000Z" />
    <EventRecordID>7630</EventRecordID>
    <Channel>Application</Channel>
    <Computer>comsrv.growth.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>IMAP4d32.exe</Data>
    <Data>2014.5.9.1517</Data>
    <Data>536d2bb4</Data>
    <Data>IMAP4d32.exe</Data>
    <Data>2014.5.9.1517</Data>
    <Data>536d2bb4</Data>
    <Data>c0000005</Data>
    <Data>000226d0</Data>
    <Data>d44</Data>
    <Data>01d29399d8c57ca8</Data>
    <Data>C:\Ipswitch\IMail\IMAP4d32.exe</Data>
    <Data>C:\Ipswitch\IMail\IMAP4d32.exe</Data>
    <Data>3e947c6e-ff90-11e6-ae80-000c29a11e28</Data>
  </EventData>
</Event>
Mike Barber
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (666 reputation)Time Traveler (666 reputation)Time Traveler (666 reputation)Time Traveler (666 reputation)Time Traveler (666 reputation)Time Traveler (666 reputation)Time Traveler (666 reputation)Time Traveler (666 reputation)Time Traveler (666 reputation)

Group: Administrators
Last Active: Last Month
Posts: 480, Visits: 19.4K
I can't tell exactly which version of IMail you have but the 12.5.x releases have included multiple fixes for IMAP crashes due to a number of different causes.
I'd suggest upgrading to 12.5.5

http://docs.ipswitch.com/_Messaging/IMailServer/v12.5.5/ReleaseNotes/index.htm#link10
http://docs.ipswitch.com/_Messaging/IMailServer/v12.5.3/ReleaseNotes/index.htm#link9
http://docs.ipswitch.com/_Messaging/IMailServer/v12.5.2/ReleaseNotes/index.htm#link3


Mike Barber
Senior Software Developer
Ipswitch, Inc
BOUTYM
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 135, Visits: 208
12.4.1.15 is the current version.  It stopped crashing for a few days and is back at it again.  It seems to happen when the IMAP gets very busy.
BOUTYM
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 135, Visits: 208
I'll try the upgrade first. I saw in the notes something that might explain issues we've had with messages disappearing also.
BOUTYM
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 135, Visits: 208
I did the upgrade and that seems to have solved the shutdown issue, but now what I get is the IMAP service pegging the CPU at 100% randomly.
Tech DW
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (356 reputation)Time Traveler (356 reputation)Time Traveler (356 reputation)Time Traveler (356 reputation)Time Traveler (356 reputation)Time Traveler (356 reputation)Time Traveler (356 reputation)Time Traveler (356 reputation)Time Traveler (356 reputation)

Group: Administrators
Last Active: 7 Months Ago
Posts: 198, Visits: 609
We have a newer build of IMAP4 for 12.5.6 that fixes that problem if you give us a call we can get you that build of IMAP.

http://kb.imailserver.com
BOUTYM
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 135, Visits: 208
Thanks.  I'll give a call because this is getting to be a problem.
BOUTYM
Posted Last Year
View Quick Profile
Time Traveler

Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)Time Traveler (269 reputation)

Group: Forum Members
Last Active: 5 Months Ago
Posts: 135, Visits: 208
As it turns out the grade did not fix the IMAP shutdown issue and the high CPU usage after the upgrade continues.  The IMAP service shuts down at least once a day at no particular time.  It's random, so can't pin it down to any particular time or event.  Driving me nuts and the users are ready to hang me.
george76
Posted Last Year
View Quick Profile
Supreme Being

Supreme Being (120 reputation)Supreme Being (120 reputation)Supreme Being (120 reputation)Supreme Being (120 reputation)Supreme Being (120 reputation)Supreme Being (120 reputation)Supreme Being (120 reputation)Supreme Being (120 reputation)Supreme Being (120 reputation)

Group: Forum Members
Last Active: 2 Months Ago
Posts: 86, Visits: 209
BOUTYM (4/7/2017)
As it turns out the grade did not fix the IMAP shutdown issue and the high CPU usage after the upgrade continues.  The IMAP service shuts down at least once a day at no particular time.  It's random, so can't pin it down to any particular time or event.  Driving me nuts and the users are ready to hang me.



I have the same problem. When the imap service is down t=i stop it, restart it, and nothing happens.
I have to restart the server, and then the imap service is working again...
My Version is 12.5.6 the latest and the Server 2008 R2

Bye...


Similar Topics


Reading This Topic